Hi Jae,
My guess as to why your system is going into emergency mode would have to do with an /etc/fstab entry for /dev/md0 that still remains even after you removed the mdadm raid.
It’s likely that the output of mount -a is:
$ sudo mount -a
mount: special device /dev/md0 does not exist
or
$ sudo mount -a
mount: can't find UUID=27f957a4-a623-4e1a-956f-9df2bcca8e75
(The UUID will be different and will be the UUID for the old Linux MD RAID.
Please do the following to fix this:
$ sudo nano /etc/fstab
# Delete or comment out the line that looks like:
/dev/md0 /data ext4 defaults 0 0
# or
UUID=17f957a4-a623-4e1a-956f-9df2bcca8e75 /data ext4 defaults 0 0
# You can add a comment by adding a # to the beginning of the line
# Write the changes to disk
# CTRL + o then ENTER then CTRL + x to
Then run sudo mount -a again and it should exit with no output. You should then be able to freely reboot with no emergency mode errors.